Mapping self-reported health status
within London from the 2011 Census
This practical is designed to be used entirely with open-source software although similar results can
be achieved with proprietary programmes.
This practical uses the following open source software:




Quantum GIS version 1.8.0 (Lisboa). If you do not have QGIS installed on your computer
already, go to http://www.qgis.org/ and download and install the appropriate version for
your operating system. *Please note, since this practical was written, QGIS version 2.0 has
been released – this version may not work as anticipated and some of the screenshots and
instructions might be a little different. If you are brave, by all means persevere but be
prepared for the odd hiccup!*
Libre Office version 4.1

By the end of this exercise, you will be able to:






download some Census data
manipulate it so that it is more appropriate for mapping
download and edit some boundary data
combine your boundary and attribute data
generate a choropleth map to visualise your data

In order to learn these skills, you will answer the following research question:

Where in London are the areas with the best and worst self-reported health?

Downloading Census Data
There are now multiple routes to accessing Census aggregate statistics and boundary data – this
practical will allow you to sample a range of routes in order that their benefits and drawbacks can be
assessed.

Route 1 – Nomis

1. Open a web browser and navigate to the 2011 Census section of the nomis website:
http://www.nomisweb.co.uk/census/2011 - here you are presented with a range of options to
access the data.
2. We are interested in Table QS302EW – General Health. This can be located a number of ways:
o The quick and dirty way is to click on the ‘Release 2 Bulk’ link under ‘Bulk download
products’ and from here download the whole England and Wales dataset for QS302EW
under ‘Quick Statistics’. This complete dataset contains several tables containing all
combinations of variables.
o Save your file to a convenient location such as C:/data and unzip it. The file containing
data for London will be in the second sub-folder and called something like
‘QS302EWDATA01_H.csv’ – the H suffix indicated the region code for London.
o The other download option is to use the data query facility. This is useful if you want to
select subsets of data in multivariate tables before downloading (this is not something
we need to do with this univariate table).
o To use this facility, either find QS302EW under the ‘Quick Statistics’ table set, or click on
the ‘Table Finder’ link and search for it in the table search box. Click ‘Select’. On the left
hand side of the page, there are a number of option – under ‘Explore’ click the
‘Advanced Query’ link (ignore wizard query).
o Click Geography > Select Areas Within and then Select all > ‘2011 Output Areas’ within >
regions and tick the box next to London.
o Click ‘General Health’ and tick the box to select all items in the column
o Click ‘Review Selections’ and check that you have 2011 output areas within London
selected and all categories under general health (should be 6 boxes ticked).
o Click format/layout and the default csv format should be selected and everything thing
else can be left as it is.

o
o

Click ‘download data’ and save your csv file to an appropriate place on your hard drive,
giving your file an appropriate name like ‘GenHealth.csv’
Open up GenHealth.csv in a package of your choice like Excel or Calc and remove the
first 9 rows of meta data, along with the row between the header and your data. You
will also need to scroll to the bottom of the file and delete the 4 lines of meta data at the
bottom, so your file looks something like the figure below.

Figure 1 – Example of cleaned GenHealth.csv file

Supplementary task: Try exploring some of the other multivariate tables
within NomisWeb and the options for downloading subsets of data

Route 2 – UK Data Service, InFuse

3. Open a web browser and navigate to http://infuse.mimas.ac.uk/ and click to login using your
institutional credentials.

4. Choose 2011 Census England and Wales
5. You will now be greeted by the topic selection screen – from here you can either scroll through
the grid selection or, alternatively, choose the ‘General Health’ filter check box on the left-hand
topic menu.
6. It is not possible to select by table name or code as with nomis, here we have to select just by
variable. Selecting the General Health filter should reduce your combination grid to one
selection (unless more data has been added since I have written this!). Select the single General
Health table by clicking the grey ‘Select’ box.
7. Click ‘next’ and then tick all six boxes for the general health variables before clicking ‘Add’ and
‘next’ again.
8. To select all of the output areas in London, expand ‘Regions’ by clicking on the ‘+’ symbol,
expand ‘London’ also and check the box next to ‘Output Areas (25053 areas)’ before clicking
‘Add’ and ‘Next’
9. You will now have the chance to change the name of your file in the file reference box if you
wish, otherwise just click the ‘Get the Data’ button and then ‘Download Data’ before saving your
file in an appropriate location, e.g. ‘C:/data’.
10. Unzip the folder and open the data file using a program like Excel or Calc. The data file will have
a name something like ‘Data_GENHEA_UNIT.csv
11. Here you will notice that there are some rows and columns which are not needed. Delete the
top row and columns 1, 3, 4 and 5 (remembering to give your first column a header name such
as ‘code’ before saving the csv file again and closing it.

Data Manipulation
Before mapping the data, first we need to normalise it in some way. It is never good practice to map
raw data, especially when the geographical zones you are using are of different size and contain
populations of varying size. Whilst output areas have more homogenous population sizes than many
other types of geographical zone in the UK, manipulating data for mapping is a useful technique to
learn.
12. Open your .csv data file for London in Libre Office Calc (Or Excel if you have it installed – both
will work in exactly the same way).
13. If you downloaded your data though the bulk download facility in Route 1, you might wish to
change the column headers for the data columns to something more understandable, such as:
All categories, Very good health, Good health, Fair health, Bad health, Very bad health.
14. Next you should calculate the totals for each column. Scroll down to the bottom row in your
data table (should be row 25054) and then row below, calculate the sum of the rows above for
column B, e.g. type ‘=SUM(B2:B25054)’ into cell B25055 and press enter. Copy this formula into
the adjacent cells C25055 to G25055 (**hint, clicking the small black square at the bottom right
corner of the cell and dragging it across will copy the formula to these adjacent cells**)
15. Next, in columns I-M, copy the titles for B-H, but include a % sign at the beginning, e.g. %All
Categories, %Very Good Health, etc.
16. In columns N-S do the same again, but this time instead of putting % at the beginning, put ‘LQ’
e.g. LQAll Categories, LQVery Good Health etc.
17. Now we will calculate the percentage of people in each Output Area that report their health as
Very Good to Very Poor. In Cell H2, type the following formula: ‘=(B2/$B2)*100’ and press enter.
The ‘$’ sign before the second ‘B’ fixes it, so when you copy the formula across to the adjacent
cells, the cell is always being divided by the cell in column B.
18. Click the small black square in the bottom right of cell H2 and drag the formula across to cell M2.

Figure 2 – Data Manipulation process

19. Now copy the whole row of formulae down to the bottom of the spreadsheet by making sure all
cells are highlighted in blue and double clicking the small black square in the bottom right hand
corner of the selection. You will down have the % distributions of the 5 health statuses for each
output area in London, plus in the very bottom row, the average self reported health distribution
for the whole city.
20. Next we will calculate a series of location quotients for these data. Location quotients compare
the local distribution of a particular variable to some global distribution and are the ratio of that
local distribution to the global distribution. Therefore, where the location quotient is greater
than 1, the variable is over-represented compared to the average, and where it is less than 1, it
is under-represented. As such, location quotients are very useful in helping us understand how,
in the context of this research, an output area might compare to the London average, when we
might not know whether a % value for poor health is actually a value we might expect or
something out of the ordinary.
21. To calculate the location quotients, first copy the following formula into cell N2: =(H2/H$25055).
This is calculating the ratio of the value of the total health distribution for the first output area,
to the total health distribution for the whole of London. As both values in this case are 100, the
ratio is 1. The ‘$’ sign this time, as it is before the numerical row element of ‘H25055’ fixes the
row when copying the formula.
22. As with the percentage calculations, copy the formula across into cell O to S and then double
click the small black square to calculate location quotients for each value of self-reported health
for each output area in London.
Figure 3 – Data Manipulation Process continued

23. Now save your file as a .csv and close it. Saving as a csv will remove any of the formulae from the
cells and leave only the results in numeric format. If asked if you are sure about saving in csv,
24. Re-open your newly saved .csv file, scroll to the bottom and delete the last row (25055)
completely. Save your file again – you are now ready to map your data once you have obtained
some boundaries.

Downloading Boundary Data
As with aggregate attribute data, for the 2011 Census there are a number of ways to access
boundary data:

Route 1 – OS Open Data
25. This is probably not the best option to choose as delivery of datasets can take days. However,
while not necessary for this task, there are a wide variety of OS map products available through
the OS Open Data portal. If you wish to try to obtain OS Boundary Line data, feel free to try by
visiting this OS download page here:
https://www.ordnancesurvey.co.uk/opendatadownload/products.html (your data may take
some days to arrive though this route)

Route 2 – ONS Open Geography GeoPortal

26. Open a web-browser and navigate to https://geoportal.statistics.gov.uk/geoportal/
27. The ‘Download Boundaries’ map facility is a little fiddly, although gives you various file format
options. More straight forward is the ‘Download Products’ facility which allows you to bulkdownload full sets of boundaries for the whole of England and Wales.
28. Click ‘Download Products’ and scroll down to ‘Boundaries :
Output_areas_(E+W)_2011_Boundaries_(Generalised_Clipped).zip’ and click on the link to
download the dataset and save to an appropriate location, e.g. ‘C:/boundaries’. Generalised
boundaries contain less data points and a consequently a slightly smaller size and therefore
easier to process. By all means experiment with the non-generalised boundaries, but be
prepared to wait a little for functions to run.
29. Unzip the file and you’ll see the various files associated with the ESRI shapefile format.

Route 3 – UK Data Service, Census Support Boundaries
30. Open a web browser and navigate to http://edina.ac.uk/census/
31. Log in using your institutional credentials.
32. It is possible to select areas that fall within higher levels of geography (OAs within Districts, for
example) using the boundary data selector, but unfortunately selecting OAs within a region is
not possible, therefore we should select whole dataset of output areas and select those that we
require later on.

33. Click on ‘Easy Download’ in the left-hand menu and then select ‘English Output Areas 2011’
before selecting the ‘English Output Areas 2011, Generalised’ option and downloading your
boundaries in ArcGIS SHAPE format. Save to an appropriate location on your hard drive.
34. Unzip the file and you’ll see the various files associated with the ESRI shapefile format.

Selecting only the Output Areas within London
To save on processing time, it is useful to select only the output areas in London before proceeding
any further. There are a number of ways to achieve this and you will find that some are more
successful than others, depending on a range of (often unforeseen) factors such as the quality of
your boundary data, quirks with the software etc.

Method 1 – Spatial Query in QGIS
This method makes use of the spatial query function in Quantum GIS. It should be pointed out now
that despite the general principle being correct, this method will not be completely successful for
this particular task. Running spatial queries is a very useful technique to master, however, so if you
would like to learn how to use this method, then continue. If you would rather skip to the method
which will work, go to method 2 below.
Before we can select the areas within London, we also need to select some regional boundary data
in order to mask the output areas we require. This method is slightly more successful with
boundaries downloaded using Route 3, but feel free to try with the boundaries from Route 2
35. If you downloaded your boundaries using Route 2, then return to the OS boundary data page
and select the ‘Boundaries :
European_electoral_regions_(GB)_2011_Boundaries_(Generalised_Clipped).zip’ file
36. If you downloaded your boundaries using Route 3, then return to the easy selection and
download English Regions 2011 and select the ‘English Regions 2011, Clipped and Generalised’
option, choosing the ArcGIS Shape option.
37. Open Quantum GIS Desktop
38. Next you will need to add two new vector layers – your OA boundaries and your region
boundaries. Click the ‘Add Vector Layer’ button (as shown below) and navigate to where your
OA and GOR boundaries are located and add them both to your map

Figure 4 – Add vector layer in QGIS

Add vector layer button

39. Make sure your region (GOR) layer is on top in the left hand layer pane. If it’s not, then just click
and drag it to the top.
40. Click the region layer in the layer pane so it is highlighted, then click the ‘Select single feature’
tool, before clicking on London on your map to highlight it in yellow (see below).
Figure 5 – Select feature

Select single feature

Highlight layer

41. Now, in the dropdown menu at the top go to Vector > Spatial Query > Spatial Query
42. In the spatial query dialogue box that pops up, complete the following query:
o Select source features from England_oa_2011_gen_clipped (or whatever your OA data
set is called) – make sure the selected geometries box is unticked.
o Where the feature *Within* Reference features of England_gor_2011_gen_clipped (or
whatever your Region dataset is called) – make sure this time the ‘1 selected
geometries’ box is ticked
o And user the result to Create New Selection
Figure 6 – Spatial Query

43. Click ‘Apply’ and QGIS should run the query and select all output areas that fall within the
London region. The window will expand after a few minutes and you will need to click ‘Apply’
again to complete the selection process.
44. In practice, some funny business goes on here and for some strange reason, only 25039 of the
25055 get selected (the equivalent operation works fine in ArcGIS, but we don’t mention that in
an open source course!)
45. If you uncheck the region layer in the layer pane, you will see your highlighted selection of OAs
(along with the odd missing zone as shown in pink within the yellow selection below).
46. If you now right-click the OA layer in the layer pane, you will see the ‘Save Selection As’ option in
the list. Clikc this and save your selection as a new ESRI Shapefile leaving all of the other options
as they are. If you would like to add your new vector layer to the map after you have done this,
check the ‘Add save file to map’ box at the bottom of the dialogue box.
47. You have now selected (most) of the output areas for London from the original shapefile and
created a new file to use in your analysis.
Figure 7 – Selected area with errors

Method 2 – Joining your data and then discarding un-joined polygons.
This method is more reliable than the spatial query method as we are joining by zone codes rather
than spatial objects. For this method, we only require the output area boundary file and the .csv file
of attributes.
48. The first thing we need to do is create a .csvt file, which will override the default tendency of
QGIS to import all data contained in a .csv file as text, even when the file contains numeric data.
The .csvt file has exactly the same name as the original .csv file and contains only one row of
data: each entry in this row tells QGIS which data type the column contains, e.g. string (text),
real (decimal number), date etc.
49. Open a new blank spreadsheet (in either Calc or Excel) and in the first row, enter the datatype
for each column, as in the example below:
Figure 8 – Format of .csvt file

50. Go to File > Save As, select ‘Save as type: Text CSV’ and save your file as ‘Untitled 1.csv’ making
sure your save your file in the same directory as your main data file. If you are using Calc, you

51.
52.
53.
54.

may have to make get an additional export box pop up – here, make sure your field delimiter is
set to comma, rather than tab or anything else. Close the file.
Navigate to your file in its directory and change the file name and extension to match the name
of your main data file with the new .csvt suffix, e.g. GenHealth.csvt.
Open QGIS desktop
Add your output area vector layer. To do this, follow the steps as in (38) and Figure 4.
Now you need to add your data layer as a vector also (even though your .csv file contains no
vector information at present). If you are unable to see your .csv file, make sure you have
changed the file type to ‘Comma Separated Value [OGR]’ as below

55. Open the attribute table of your Output Area shapefile by right-clicking on the shapefile in the
layer pane and selecting ‘Open Attribute Table’. Here you will be able to see all of the data
associated with your shapefile and the name of the column you will be joining your attribute
data on. In this case, there should only be one column. Close your attribute table.
56. Double click your OA layer and the layer properties box should open up. Click on the ‘Joins’ tab
and click the ‘+’ sign to join some data to your output area file. As we only have one data table
open in our project, QGIS should automatically find this layer. Check that the ‘join field’ is the
column in your .csv that contains the output area codes and that the ‘target field’ is also the
column in your shapefile that contains the output area codes. If everything is correct, click ‘OK’
and then ‘OK’ again and QGIS should perform the data join operation.

57. Now if you open the attribute table for your Output Area shapefile, you should see that the
columns of your data file have been appended (although the top rows will likely contain ‘NULL’
values).
58. Next we need to delete all of the output areas that don’t contain any data (those outside of
London). With the attribute table still open, click the ‘Advanced Search’ button at the bottom of
the table.
59. The Search query builder will now allow us to select only the rows in the table (polygons in the
shapefile) that contain data. To do this we need to select those rows that don’t contain null
values. Double click any of the data fields in the field list and you will see it appear in the SQL box
at the bottom. Next click the not equal to (!=) button, and finally type manually ‘NULL’ (including
the quotation marks) into the box. Your query should look something like the example below:

60. Click ‘OK’ and your query should run and return 25053 features selected. You should now see
the selected output areas highlighted in yellow on your map.
61. Right-click your output area layer in the layer pane to the left and click ‘Save Selection As’ Save
in ESRI Shapefile format and save your new shapefile with a name of your choice to an
appropriate location on your hard drive – check the ‘Add saved file to map’ box at the bottom of
the dialog box to add your new London boundary file with attached data to the map window.
You can now right-click and remove the other layers from your project.

Creating a choropleth map of self-reported health status within London
Before you can generate a map of self-reported health within London, you should have joined your
data to your map boundaries. If you only chose Method 1 above, work through Method 2 as well to
join your data to your boundaries.
62. In the layer pane, double click the layer that contains your data joined to your London output
area boundaries, this will open the layer properties dialogue box. The left-most tab should be
the ‘Style’ tab. The properties dialogue box should open by default in this tab, but if not, click on
the Style tab.
63. We will now generate a choropleth map to show the location quotients of very good selfreported health. If you remember from point 20 above, location quotients are a ratio of an
area’s distribution for a particular variable, compared to some global distribution. In our case,
we will be interested in looking at how very good self-reported health in a particular output
areas compares to very good self-reported health across the whole of London. Because the

location quotient is a ratio, areas scoring greater than 1 will have an above average instance of
very good health; those scoring less than one, a below average instance.
64. In the top left of the ‘Style’ tab, change the display option from single symbol to ‘Graduated’ in
the drop down menu. Under ‘Column’ select column with the location quotient for very good
health.
65. Under ‘Color ramp’, select ‘New color ramp…’ > ColorBrewer and then click ‘OK’. Find the
‘Spectral’ scheme under the scheme name options and change the number of colours to 6
before clicking ‘OK’ and then giving your colour ramp a title if you wish.

66. Now, change ‘Classes’ to 6 and ‘Mode to ‘Natural Breaks (Jenks)’. If you click the box next to
‘Symbol’ and then the
button, you should then change ‘Border style’ to ‘No
Pen’ to remove all boundary outlines. Click OK until you get back to the layer properties box.
67. You should now have six colour categories with ranges similar to the ones shown in the figure
above. As we want the map to differentiate between values above and below 1, you should
change the range slightly so that the third range down ends at 1 and the fourth range down
starts at 1. To do this, simply double click the range and alter the upper or lower value
accordingly. Once you have done this, click OK and your choropleth map showing the areas in
London with above and below average very good health should be clearly displayed.

Saving your project and printing your map
68. Once you have generated your map, you can save your QGIS project by going to File > Save
Project As and save your project to a suitable location.
69. If you wish to prepare your map for publication, then open up the print composer by going to
File > New Print Composer
70. Inside the print composer you can add and edit a legend, add a scale bar, north arrow and title
and then export your map either as an image or PDF

Mapping data from Eurostat using R
All of the details for this practical exercise can be found at the
following web address:
http://rpubs.com/adam_dennett/8955

